Author Topic: problem re throttle position sensor. how to test?  (Read 188 times)

devon jazz

  • New Member
  • Posts: 4
  • Country: gb
problem re throttle position sensor. how to test?
« on: April 08, 2021, 05:37:44 PM »
Hi,

just been given  a 2005 Jazz 1.4 CVT SE, its been sat for two years as father in law wanted to drive again but has now had to give up. I fitted new battery, and car started, revs went up and down oscillating  700-2000 when in park but otherwise fine, drove to MOT, straight through passed emissions test. guy at garage suggested tapping lightly the throttle position sensor and the  idle air supply valve. i tapped TPS with handle of screwdriver and the revs stopped oscillating, but now the idle is low and when cold stalls when put in in  D or R, it will just about hold a low idle in D and R when warm. the engine management light has come on code reader says P0122, throttle position sensor.
having read forums there is mention of a broken wire in loom. i have tested the TPS, putting paperclip in back of plug from loom when connected to TPS, it gets a 5v supply ok and the ground at plug ok. the middle pin in plug has no voltage showing whether i turn the throttle wide open or closed.

my question  is - is this a sign of a broken wire in loom or a broken tps, and hence i hunt a new throttle body on ebay?
is there a way of testing TPS when unplugged?

thanks for any help in advance

jaytee

  • Approved Member
  • *
  • Posts: 19
  • Country: gb
  • My Honda: 2012 1.4 es
Re: problem re throttle position sensor. how to test?
« Reply #1 on: April 08, 2021, 06:35:01 PM »
had a similar problem, was ready to buy a new TPS. saw advice on here about faulty green/yellow wire. got a garage to check, all sorted for under 100 quid. video on youtube explains give it a try

devon jazz

  • Topic Starter
  • New Member
  • Posts: 4
  • Country: gb
Re: problem re throttle position sensor. how to test?
« Reply #2 on: April 08, 2021, 07:38:20 PM »
Thanks JT, thats helpful. i'd seen the posts about yellow/green wire break, however the yellow/green wire is giving a constant 5V at the plug and the sensor even when i wiggle the harness , its the signal wire that has zero voltage, is anyone aware of the signal wire breaking? or is it likely a duff sensor?

Jocko

  • Approved Member
  • *
  • Posts: 7326
  • Country: scotland
  • Fuel economy:
  • My Honda: 2006 GD5 Jazz 1.2 i-DSi S in Vivid Blue Pearl
Re: problem re throttle position sensor. how to test?
« Reply #3 on: April 08, 2021, 10:26:28 PM »
Have you tried an ohmmeter on the sensor?

Check this for possible help.

http://www.hondafitjazz.com/manual/A00/HTML/98/SAA2E98K72100081071FAAT00.HTML

devon jazz

  • Topic Starter
  • New Member
  • Posts: 4
  • Country: gb
Re: problem re throttle position sensor. how to test?
« Reply #4 on: April 13, 2021, 09:08:57 PM »
i bought a second hand throttle body with working TPS,  this resolved the EML after clearing codes, but back to fluctuating revs remained.  removed the idle air control valve off new and replacement throttle bodies, both were stuck open. carb cleaner to both and some light oil to both an both closed on the spring and freed up.  fitted one back to replacement throttle body and idle back to normal. sorted.  thanks for everyone's suggestions

Tags:
 

Back to top